Notice: Area51 VPS and Cloud services are NOT vulnrable to Intel security holes

All systems and services at Area51 are utilizing AMD Server infrastructure and therefore are not vulnerable due to architecture differences.

To Clarify here are the current major exploits this notice addresses,

  • Rogue Data Cache Load
  • Branch Target Injection

The Bounds Check Bypass was already addressed by a security patch.

If you have any questions please feel free to contact us.

Comments are closed