Security Update: Email Services

SHA-2

Compatibility Notes

Email Clients:

  • Outlook 2007 on Windows Vista+
  • Outlook on Mac 2011
  • Microsoft Entourage 2008
  • IBM Notes 9+
  • Thunderbird 38+

Others:

  • Microsoft Windows XP SP3+
  • Windows Server 2003+
  • Windows Phone 7+
  • Apple Mac OSX 10.5+
  • Apple iOS 3.0+
  • Oracle Java 1.4.2+
  • Mozilla Firefox 1.5+
  • Opera 9+
  • ChromeOS All
  • Blackberry 5.0+
  • Android 1.0(1.6 / 2.2 )+
  • Internet Explorer 6+
  • Netscape 7.1+

With all of the recent hacking like the 1 million google accounts being hijacked we've increased security on email services as part of that we've disabled some older less secure SSL technologies. If you are getting an error connecting via SSL it means that the device doesn't support the newer SSL Cyphers or for some reason your Internet provider, or device has cached the old SSL certificate, which would also cause problems you can use a non secure port. However, this is not secure and thus the recommended solution is to update older devices or clear the cache.

Non SSL Ports:
IMAP: 143
POP3: 110
SMTP: 25 or 26

SSL PORTS:
IMAP: 993
POP3: 995
SMTP: 465 or 587

Comments are closed